Jump to content
PixelRobot

Having trouble setting up Kitto Kitto Kitto (fixed)

Recommended Posts

I decided to use the Kitto script to try to make a pet sim on AlterVista. I followed the documentation and the errors on my site never went away after I finished installing the script. I think it may have been because I didn't chmod the directories, but I didn't know how to do it in AlterVista. Here is my site. Kitto doesn't have an active forum/contact section so I'm stumped.

 

Edit:

Finally was able to get it fixed! So, the issue was that I didn't have the right paths for the Smarty template directory and HTMLPurifier cache. To get the path, I had to check system_check.php, which lists the base path when looking at your file directory (in AlterVista it's under "File Management").
So let's say the path was: 'base_path' => '/membri/YOURSITE',

 

So the smarty template directory is therefore : 'template_path' => '/membri/YOURSITE/template',

 

And the HTMLPurifier cache path was: 'htmlpurifier_cachedir' => '/membri/YOURSITE/cache',

Edited by PixelRobot
Fixed the issues :D Thanks again, judda!
Link to comment
Share on other sites

@PixelRobot What version of PHP are you running it on? The deprecated stuff is typically caused by using a newer version,  My first thought is you are running on PHP 7.X when it's likely supposed to run on PHP 5.6.

For the following error:

Warning: file_exists(): open_basedir restriction in effect.

It looks like the root/base path is wrong (pointing to /var/www/)

Link to comment
Share on other sites

31 minutes ago, judda said:

@PixelRobot What version of PHP are you running it on? The deprecated stuff is typically caused by using a newer version,  My first thought is you are running on PHP 7.X when it's likely supposed to run on PHP 5.6.

For the following error:

Warning: file_exists(): open_basedir restriction in effect.

It looks like the root/base path is wrong (pointing to /var/www/)

@judda

I'm running it on 5.6.40. How do I change the base path (and know what the right one is?)

 

The config.inc file says to "Consult your system_check.php file for this path." And the says the base directory is 

/membri/reim

 

The system check file says everything looks good.

Edited by PixelRobot
Link to comment
Share on other sites

@PixelRobot Try to change the base path to:

./membri/reim

The fact that it starts with a "/" means that it will read from the server's root which is not correct.

Is there an .htaccess for or anything? If yes, try the following:

https://blog.domainracer.com/hide-turn-off-php-warning-errors-htaccess-cpanel.jsp

Link to comment
Share on other sites

1 hour ago, judda said:

@PixelRobot Try to change the base path to:

./membri/reim

The fact that it starts with a "/" means that it will read from the server's root which is not correct.

Is there an .htaccess for or anything? If yes, try the following:

https://blog.domainracer.com/hide-turn-off-php-warning-errors-htaccess-cpanel.jsp

@judda

I tried it but it still shows the errors.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines, Terms of Use, and Privacy Policy.