Jump to content

Project: Petsite - Open registration + new world map!


Recommended Posts

You're welcome to claim your favorite username and play in some the core features we opened with, break stuff and let us know what to fix in the onsite forums!

Many many more updates to catch up in discord news and dev log channels, your invite is on ProjectPetsite.com/discord


Map art was done by Hornbuckle, and each element themed section of the map will have it's own land.

Edited by Claws
Link to comment
Share on other sites

Ah. My favorite part of User Experience Testing; breaking stuff. 

Sure. Let's give it a whirl. 

Spoiler'd because it's a Wall - 


The game looks simple, but it passes the First Impression Test; I was able to see the last time the game was updated without registering. 

Footer Content here

Registration was quick and easy ... but are you sure you don't want people to confirm password? 

Logging in takes me to the News Page which explains this is an Alpha. Now I have to poke around and see what's working and what is intentionally disabled (/not a hint). 

Let's go Adopt a Pet. 

I ... didn't like any of the pets enough to want to immediately adopt one. I decided to take a different approach and adopt a species/typing combination that only one pet has; Mech Puppen. I went with female assuming that breeding is going to be a part of this and eventually there will be little puppens. 

Thought it was strange getting an alert-style popup for a confirmation that the pet was created. That's temporary? 

Just for kicks I decided to try adopting a Male Puppen of another type. I got an alert saying that it was successful. 

Now, where do I go to see my pets? 

I decided to click on my username and go to this page. 

There's a noticeable flicker where the script presumably goes and fetches the data from the ... API? I'm still learning but got the general gist of what happened. 

It appears as though some things are broken on this page - 


1. Avatar is Broken 
2. None of these buttons appear to work 
3. Looks like it tried, and failed, to pull my pets 


Next Up: Explore 

There seem to be some stuff locked away. I see if I can Neopets my way in later on. 

Wild Card Table 

Wow. A much prettier notification than the one on Adopt-a-Pet was used when I select my card.
Can't close it, though. 

I refreshed, but got a notification that I can't select another card so this appears to be working. 
I like the countdown. I'll be back at the top of the hour. 

Clicking on Return to Explore worked before I drew my card. 
When I clicked on Return to Explore after drawing it redirected to this page. 


Hm. I have both of my pets, but also noticed at this point I was missing 3,000 Gold. 
Did it charge me Gold to adopt the second Puppen without telling me? 
I also noticed both of my Puppens are male even though the Mech should be a female. 

Card Trade Machine 

I don't have enough cards so I can't do anything here. 
Go Back to Saloon? What Saloon? 

*click* Got redirected here

Decided to click on Dealer's Choice since it's the only one I haven't seen yet. 

This was more visible the first time I went to the page, but when I retraced my steps to document this I can barely see what's here. 


How to Play leads nowhere. There is also no button to return to Explore. 

Mineral Cavern 

No problems to report. 

Spy Glass 

There is no button to return to Explore if I don't want to collect. 
The button showed up when I collected. 


There is no button to return to Explore if you decide not to play. 
The button didn't show up when I finished collecting the toys. I was able to choose three. 
This page has a static countdown compared to the Card Daily. 

I couldn't guess any of the other locations yet so I decided to leave Explore alone for now. People on Neopets are able to find a ton of content before its released by getting lucky with search, page and item parameters. TNT caught on and began randomizing parameters for Events before the Staffing Shuffle. I'll explain why this is important in a minute. 

I clicked on the Puppen and got to set my active. That still didn't fix what was shown in Image 1 above. 
As you mentioned naming a pet isn't working on this page -- but it's not throwing an error/warning, either. 

Clicked on Backpack. All of the items I obtained so far are here. 
Shop, Gallery, and Vault lead nowhere. 

I couldn't do anything with the Mineral, so I decided to go through the actions with the other items. 
Playing worked. Mood, a stat I couldn't find or see, improved. 
Enhancing Speed, whatever that is, appeared to work. 
Sending to the Market threw this error - 


When I closed the alert the item box broke - 


Discarding worked. 

I just noticed I could set both of my Puppens to active. Hm. 

Time to go Shopping 

Goodness, there's a lot of food in this shop. And it all appears to be of varying size. 

Buying items seems to work, but the flow is a little strange. 
Maybe it has to do with the item showing up in a popup. 
It's not broken, but also not what I'm used to. 

The descriptions for buying items in the shops seem to remain the same for that item type, which is strange. 


... or maybe it is broken. Or something's off.

I noticed my on-hand amount wasn't changing, but that was because it didn't auto-refresh like most things. I didn't notice that it was actually deducting until I was told I did not have enough money to purchase something. I decided to refresh and, yep, money was being deducted from my on-hand. 

Only the Food Shop NPC's image is not broken. The rest flicker and break. 

Healing and improving Health of the pet both seem to work ... though I'm not sure what the difference is. 
I could only buy one book at this point so I chose Study, which seems to work. Not sure the difference between reading and studying. 

The armor's description seems to imply that it can be equipped, but it asks me to train defense instead. 


The Grappling Hook is said to be a crafting item, but it asks me to train strength instead. 


Just for kicks I decided to guess what the ID was for the Potion Shop. I could get in. 


Nothing else seemed to be working and I had to come back tomorrow to earn more money to spend and test items with, so I logged out for now. 

When I logged out I noticed a Help section, but clicking it produced nothing. 


  • Thanks 1
Link to comment
Share on other sites

Little notes:

1) No need to confirm email? I can type in any ol' email and spam the place and take up accounts or cause chaos.
2) Bookstore link on the news page at the top is broken and goes no where.
3) Underneath the update "Fixes!" the link to the bug forum takes me no where as well.
4) I bought a second pet, there was no confirm to ask me if I REALLY wanted to buy the pet. Can you please add in that option?
5) You have it labeled as boards, but wouldn't it be more appropriate to call it the forum? Just a general thing though, not a big deal.
6) Is the gear supposed to give user preferences or settings? It does a little white flash, then nothing shows up.

Looking cute so far! Keep up the great work.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...